Skip to content

ElementGroupElement

Canonical path: NemAll_Python_BasisElements.ElementGroupElement

Bases: BasisElement, AllplanElement

Representation of the element group in Allplan.

Element group can be used to organize model elements of any kind (architectural components, general elements...) into groups with a Parent-Child relationship, where the group is the parent, and all elements are children.

Methods:

GetElementGroupProperties

GetElementGroupProperties() -> ElementGroupProperties

Get the ElementGroup properties

Returns:

GetObjectList

GetObjectList() -> list

Get the list of element group objects

Returns:

  • list

    Element group object list

SetElementGroupProperties

SetElementGroupProperties(ElementGroupProp: ElementGroupProperties)

Set the ElementGroup properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(
    commonProp: CommonProperties,
    elementGroupProp: ElementGroupProperties,
    elementGroupObjectList: list,
)

Default constructor

Parameters:

  • commonProp (CommonProperties) –

    Common properties

  • elementGroupProp (ElementGroupProperties) –

    Properties of the element group

  • elementGroupObjectList (list) –

    List of objects to put in the group

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string