Skip to content

TextureDefinition

Canonical path: NemAll_Python_BasisElements.TextureDefinition

Representation of the texture definition

Methods:

  • __eq__

    Compare operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

Attributes:

SurfacePath property

SurfacePath: None

Property for surface path

:type: None

__eq__

__eq__(props: TextureDefinition) -> bool

Compare operator

Parameters:

Returns:

  • bool

    Properties a equal: true/false

__init__ overloaded

__init__()

Initialize

__init__(surfacePath: str)

Constructor

Parameters:

  • surfacePath (str) –

    Surface path of texture definition

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string