Skip to content

TextureMappingType

Canonical path: NemAll_Python_BasisElements.TextureMappingType

Bases: Enum

Types of texture mapping

Attributes:

  • eCube

    From each side

  • eCylinder

    Cylindrical mapping

  • eGround

    Only from the top view

  • eRoof

    Mainly from the top view

  • eSphere

    Spherical mapping

  • eUV

    UV mapping

  • eWall

    Mainly from the front view

eCube class-attribute instance-attribute

eCube = 0

From each side

eCylinder class-attribute instance-attribute

eCylinder = 4

Cylindrical mapping

eGround class-attribute instance-attribute

eGround = 3

Only from the top view

eRoof class-attribute instance-attribute

eRoof = 2

Mainly from the top view

eSphere class-attribute instance-attribute

eSphere = 5

Spherical mapping

eUV class-attribute instance-attribute

eUV = 6

UV mapping

eWall class-attribute instance-attribute

eWall = 1

Mainly from the front view