Skip to content

ClosedAreaComposite3D

Canonical path: NemAll_Python_Geometry.ClosedAreaComposite3D

3D closed area composite Representation class for 3D geometry profile composite

Methods:

  • Add

    Add new profile

  • Clear

    Clear contents of this composite

  • GetClosedAreaComposite

    Get constant reference to composite of ClosedArea2D

  • GetRefPlacement

    Get axis placement

  • IsEmpty

    Check if this composite has any contents ( profiles )

  • SetRefPlacement

    Set axis placement

  • __eq__

    Comparison of closedAreaComposites without tolerance.

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

Attributes:

ClosedAreaComposite property

ClosedAreaComposite: None

Get the 2d closed area composite as property

:type: None

RefPlacement property

RefPlacement: None

Get and set the reference placement 3d as property

:type: None

Add

Add(profile: ClosedArea2D) -> bool

Add new profile

Parameters:

Returns:

  • bool

    true if the operation was successful

Clear

Clear()

Clear contents of this composite

GetClosedAreaComposite

GetClosedAreaComposite() -> ClosedAreaComposite2D

Get constant reference to composite of ClosedArea2D

Returns:

GetRefPlacement

GetRefPlacement() -> AxisPlacement3D

Get axis placement

Returns:

IsEmpty

IsEmpty() -> bool

Check if this composite has any contents ( profiles )

Returns:

  • bool

    true if it is empty

SetRefPlacement

SetRefPlacement(placement: AxisPlacement3D)

Set axis placement

Parameters:

__eq__

__eq__(closedAreaComposite: ClosedAreaComposite3D) -> object

Comparison of closedAreaComposites without tolerance.

Be careful, this method work without tolerance!

Parameters:

Returns:

  • object

    True when closedAreaComposites are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(composite: ClosedAreaComposite3D)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string