Skip to content

Polyhedron3DBuilder

Canonical path: NemAll_Python_Geometry.Polyhedron3DBuilder

3D polyhedron builder

Methods:

AppendVertex

AppendVertex(vertex: Point3D) -> tuple

Append new vertex

Parameters:

  • vertex (Point3D) –

    Point in world coordinate system

Returns:

  • tuple

    eOK if success,

  • tuple

    Index where vertex has been inserted

Complete

Complete() -> eGeometryErrorCode

Finalize polyhedron

Recalculate cached minmax of modified polyhedron

SetVertex

SetVertex(vertexIndex: int, vertex: Point3D) -> eGeometryErrorCode

Set vertex at the given index

Parameters:

  • vertexIndex (int) –

    Index of updated vertex

  • vertex (Point3D) –

    Point in world coordinate system

Returns:

__init__

__init__(polyhedron: Polyhedron3D)

Constructor

Parameters:

  • polyhedron (Polyhedron3D) –

    Polyhedron where vertices will be modified