Skip to content

MeshAreaPlacementService

Canonical path: NemAll_Python_Reinforcement.MeshAreaPlacementService

Methods:

AddOpeningPolygon

AddOpeningPolygon(arg2: Polygon3D, openingPol: float)

Add an opening polygon

Parameters:

  • openingPol (float) –

    Opening polygon

Calculate

Calculate(
    arg2: DocumentAdapter,
    doc: MeshData,
    mesh: MeshAreaPlacementProperties,
    placementMatrix: Matrix3D,
    startPositionNumber: int,
    concreteCoverZDir: float,
) -> list

Calculate the meshes

Parameters:

  • doc (MeshData) –

    Document

  • mesh (MeshAreaPlacementProperties) –

    Mesh data

  • placementMatrix (Matrix3D) –

    Placement matrix

  • startPositionNumber (int) –

    Start position number

  • concreteCoverZDir (float) –

    Concrete cover in the local z direction

SetOuterPolygon

SetOuterPolygon(arg2: Polygon3D, placementPol: float)

Constructor

Parameters:

  • placementPol (float) –

    Placement polygon

__init__

__init__()

Initialize