Skip to content

FilletCalculus2D

Canonical path: NemAll_Python_Geometry.FilletCalculus2D

Class for fillet calculation between two 2D objects

Methods:

ClickedOnObject overloaded

ClickedOnObject(
    line: Line2D, clickedPoint: Point2D, searchRadius: float
) -> bool

Check if click point is a point located on given line

Parameters:

  • line (Line2D) –

    Line2D which will be checked

  • clickedPoint (Point2D) –

    clicked point

  • searchRadius (float) –

    search radius

Returns:

  • bool

    true if point is on the line

ClickedOnObject(arc: Arc2D, clickedPoint: Point2D, searchRadius: float) -> bool

Check if click point is a point located on given arc

Parameters:

  • arc (Arc2D) –

    Arc2D which will be checked

  • clickedPoint (Point2D) –

    clicked point

  • searchRadius (float) –

    search radius

Returns:

  • bool

    true if point is on the arc

GetArcHelpConstructions

GetArcHelpConstructions() -> Arc2DList

Get all arc help constructions

Returns:

GetFilletType overloaded

GetFilletType(line1: Line2D, line2: Line2D) -> eFilletType

Get fillet type for two lines

Parameters:

  • line1 (Line2D) –

    first line

  • line2 (Line2D) –

    second line

Returns:

GetFilletType(line: Line2D, arc: Arc2D) -> eFilletType

Get fillet type for line and arc

Parameters:

Returns:

GetFilletType(arc1: Arc2D, arc2: Arc2D) -> eFilletType

Get fillet type for two arcs

Parameters:

  • arc1 (Arc2D) –

    first arc

  • arc2 (Arc2D) –

    second arc

Returns:

GetFilletType(geometry1: object, geometry2: object) -> eFilletType

Get fillet type for two geometry objects

Parameters:

  • geometry1 (object) –

    first geometry element

  • geometry2 (object) –

    second geometry element

Returns:

GetFillets

GetFillets() -> Arc2DList

Get all possible fillets

Returns:

GetLineHelpConstructions

GetLineHelpConstructions() -> object

Get all line help constructions

Returns:

  • object

    all line help constructions

GetNearest

GetNearest(point: Point2D) -> Arc2D

Get the nearest fillet to the point

Parameters:

Returns:

  • Arc2D

    nearest arc to the point

SplitPolylineBySegment staticmethod

SplitPolylineBySegment(polyline: Polyline2D, segment: int) -> tuple

Split polyline by given segment

Parameters:

  • polyline (Polyline2D) –

    polyline which will be split by given segment

  • segment (int) –

    segment where polyline will be split

Returns:

  • tuple

    first part of polyline,

  • tuple

    second part of polyline

TrimByHelpConstruction overloaded

TrimByHelpConstruction(
    line: Line2D, hcLine: Line2D, intersections: Point3DList
) -> Line2D

Trim line by given help construction

Parameters:

  • line (Line2D) –

    line which will be trimmed

  • hcLine (Line2D) –

    line help construction

  • intersections (Point3DList) –

    intersection points

Returns:

  • Line2D

    line which will be trimmed

TrimByHelpConstruction(
    polyline: Polyline2D,
    segment: Line2D,
    hcLine: Line2D,
    intersections: Point3DList,
) -> Polyline2D

Trim polyline by given help construction

Parameters:

  • polyline (Polyline2D) –

    polyline which will be trimmed

  • segment (Line2D) –

    selected segment

  • hcLine (Line2D) –

    line help construction

  • intersections (Point3DList) –

    intersection points

Returns:

TrimByHelpConstruction(
    arc: Arc2D, hcArc: Arc2D, intersections: Point3DList
) -> Arc2D

Trim arc by given help construction

Parameters:

  • arc (Arc2D) –

    arc which will be trimmed

  • hcArc (Arc2D) –

    arc help construction

  • intersections (Point3DList) –

    intersection points

Returns:

  • Arc2D

    arc which will be trimmed

UpdateBySelectedHelpConstruction overloaded

UpdateBySelectedHelpConstruction(
    polyline: Polyline2D,
    segment: Line2D,
    trimHelpConstruction: object,
    intersection: Point2D,
) -> Polyline2D

Update polyline by selected help construction

Parameters:

  • polyline (Polyline2D) –

    polyline which will be updated

  • segment (Line2D) –

    selected segment

  • trimHelpConstruction (object) –

    help construction data

  • intersection (Point2D) –

    intersection

Returns:

UpdateBySelectedHelpConstruction(
    line: Line2D, trimHelpConstruction: object, intersection: Point2D
) -> Line2D

Update line by selected help construction

Parameters:

  • line (Line2D) –

    line which will be updated by help construction

  • trimHelpConstruction (object) –

    help construction data

  • intersection (Point2D) –

    intersection

Returns:

  • Line2D

    line which will be updated by help construction

UpdateGeometry overloaded

UpdateGeometry(geoArc: Arc2D, fillet: Arc2D, selectedGeometry: object) -> Arc2D

Update arc geometry

Parameters:

  • geoArc (Arc2D) –

    arc which will be updated

  • fillet (Arc2D) –

    Arc2D

  • selectedGeometry (object) –

    selected geometry

Returns:

  • Arc2D

    arc which will be updated

UpdateGeometry(
    geoPolyline: Polyline2D,
    fillet: Arc2D,
    selectedGeometry1: object,
    selectedGeometry2: object,
) -> Polyline2DList

Update polyline geometry

Parameters:

  • geoPolyline (Polyline2D) –

    polyline which will be updated

  • fillet (Arc2D) –

    Arc2D

  • selectedGeometry1 (object) –

    First selected segment

  • selectedGeometry2 (object) –

    Second selected segment

Returns:

UpdateGeometry(
    geoPolyline: Polyline2D, fillet: Arc2D, selectedGeometry: object
) -> Polyline2D

Update polyline geometry

Parameters:

  • geoPolyline (Polyline2D) –

    polyline which will be updated

  • fillet (Arc2D) –

    Arc2D

  • selectedGeometry (object) –

    selected geometry

Returns:

UpdateGeometry(
    geoPolyline: Polyline2D,
    fillet: Arc2D,
    selectedGeometry1: object,
    selectedGeometry2: object,
    segmentCount: int,
) -> Polyline2D

Update polyline geometry

Parameters:

  • geoPolyline (Polyline2D) –

    polyline which will be updated

  • fillet (Arc2D) –

    Arc2D

  • selectedGeometry1 (object) –

    the first selected geometry

  • selectedGeometry2 (object) –

    the second selected geometry

  • segmentCount (int) –

    required count of segments of the polygonized fillet

Returns:

UpdateGeometry(
    geoPolygon: Polygon2D,
    fillet: Arc2D,
    segment1: Line2D,
    segment2: Line2D,
    segmentCount: int,
) -> Polygon2D

Update polyline geometry

Parameters:

  • geoPolygon (Polygon2D) –

    polygon which will be updated

  • fillet (Arc2D) –

    Arc2D

  • segment1 (Line2D) –

    first selected geometry

  • segment2 (Line2D) –

    second selected geometry

  • segmentCount (int) –

    required count of segments of the polygonized fillet

Returns:

  • Polygon2D

    geoPolygon which will be updated

UpdateGeometry(geoSpline: Spline2D, fillet: Arc2D) -> Spline2D

Update spline geometry

Returns:

  • Spline2D

    spline which will be updated

UpdateGeometry(
    geoLine: Line2D, fillet: Arc2D, selectedGeometry: object
) -> Line2D

Update lien geometry

Parameters:

  • geoLine (Line2D) –

    line which will be updated

  • fillet (Arc2D) –

    Arc2D

  • selectedGeometry (object) –

    selected geometry

Returns:

  • Line2D

    line which will be updated

__init__ overloaded

__init__(line1: Line2D, line2: Line2D, r: float)

constructor

Parameters:

  • line1 (Line2D) –

    Line2D

  • line2 (Line2D) –

    Line2D

  • r (float) –

    radius

__init__(line: Line2D, arc: Arc2D, r: float)

constructor

Parameters:

  • line (Line2D) –

    Line2D

  • arc (Arc2D) –

    Arc2D

  • r (float) –

    radius

__init__(arc1: Arc2D, arc2: Arc2D, r: float)

constructor

Parameters:

  • arc1 (Arc2D) –

    Arc2D

  • arc2 (Arc2D) –

    Arc2D

  • r (float) –

    radius

__init__(arc: Arc2D, point: Point2D)

constructor

Parameters:

__init__(line: Line2D, point: Point2D)

constructor

Parameters:

__init__(geoObj1: object, geoObj2: object, r: float)

constructor

Parameters:

  • geoObj1 (object) –

    IGeometry object

  • geoObj2 (object) –

    IGeometry object

  • r (float) –

    radius