Skip to content

PolygonalArea

Canonical path: NemAll_Python_Geometry.PolygonalArea

Methods:

AppendEdge

AppendEdge(edge: GeometryEdge) -> eGeometryErrorCode

Append edge (appendPolygonEdge).

Parameters:

Returns:

GetComponentsCount

GetComponentsCount() -> int

Get count of components.

Returns:

  • int

    Count of component.

GetEdge

GetEdge(edgeIndex: int) -> tuple

Get edge.

Parameters:

  • edgeIndex (int) –

    index of the edge.

Returns:

  • tuple

    Error code.,

  • tuple

    edge of polygon.

GetEdges

GetEdges() -> tuple

Get copy of all edges.

Returns:

  • tuple

    Error code.,

  • tuple

    vector of all edges.

GetEdgesCount

GetEdgesCount() -> int

Get count of edges.

Returns:

  • int

    Count of edges.

GetLoopEndEdgeIndex

GetLoopEndEdgeIndex(loopIndex: int) -> int

Get the index of last edge of a loop.

Parameters:

  • loopIndex (int) –

    index of loop.

Returns:

  • int

    Index of the last edge of the loop identified by the loopIndex value.

GetLoopsCount

GetLoopsCount() -> int

Get Count of loops.

Returns:

  • int

    Count of loops.

GetNeighborEdges

GetNeighborEdges(edgeIndex: int) -> tuple

Get neighbor edges.

Parameters:

  • edgeIndex (int) –

    edge index.

Returns:

  • tuple

    Error code.,

  • tuple

    previous edge (edge which is before edge[index] in the chain).,

  • tuple

    next edge (edge which is after edge[index] in the chain).

GetNextEdge

GetNextEdge(edgeIndex: int) -> tuple

Get next edge.

Parameters:

  • edgeIndex (int) –

    edge index.

Returns:

  • tuple

    Error code.,

  • tuple

    next edge (edge which is after edge[index] in the chain).

GetPlane

GetPlane() -> tuple

Get plane if polygon is plane.

Returns:

GetPrevEdge

GetPrevEdge(edgeIndex: int) -> tuple

Get previous edge.

Parameters:

  • edgeIndex (int) –

    edge index.

Returns:

  • tuple

    Error code.,

  • tuple

    previous edge (edge which is before edge[index] in the chain).

GetVector

GetVector() -> tuple

Get Normal vector if polygon is plane.

Returns:

  • tuple

    Error code.,

  • tuple

    normal vector to the polygon plane.

GetVerticesCount

GetVerticesCount() -> int

Get count of vertices.

Returns:

  • int

    Count of vertices.

SetPlane

SetPlane(plane: Plane3D)

Set plane.

Parameters:

  • plane (Plane3D) –

    plane which will be set.

SetVector

SetVector(vec: Vector3D) -> eGeometryErrorCode

Set normal vector.

Parameters:

  • vec (Vector3D) –

    vector which will be set.

Returns: