Skip to content

AllplanPaths

Canonical path: NemAll_Python_AllplanSettings.AllplanPaths

Class for getting Allplan paths

Methods:

GetCurPrjDesignPath staticmethod

GetCurPrjDesignPath() -> str

Get the current project design path

Returns:

  • str

    Current project design path

GetCurPrjPath staticmethod

GetCurPrjPath() -> str

Get the current project path

Returns:

  • str

    Current project path

GetEtcPath staticmethod

GetEtcPath() -> str

Get the Etc path

Returns:

  • str

    Etc path

GetPathOfApplication staticmethod

GetPathOfApplication() -> str

Get the path of the application

Returns:

  • str

    Path of the application

GetPrgPath staticmethod

GetPrgPath() -> str

Get the program path

Returns:

  • str

    Program path

GetPythonPartsEtcPath staticmethod

GetPythonPartsEtcPath() -> str

Get the PythonParts Etc path

Returns:

  • str

    Etc path

GetStdDesignPath staticmethod

GetStdDesignPath() -> str

Get the Std design path

Returns:

  • str

    Std design path

GetStdPath staticmethod

GetStdPath() -> str

Get the Std path

Returns:

  • str

    Std path

GetTmpPath staticmethod

GetTmpPath() -> str

Get the Tmp path

Returns:

  • str

    Tmp path

GetUsrPath staticmethod

GetUsrPath() -> str

Get the Usr path

Returns:

  • str

    Usr path