Skip to content

MacroGroupProperties

Canonical path: NemAll_Python_BasisElements.MacroGroupProperties

Properties of the macro group.

Methods:

  • __eq__

    equal operator

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert to string

Attributes:

  • Name (str) –

    Name

Name property writable

Name: str

Name

__eq__

__eq__(prop: MacroGroupProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__ overloaded

__init__()

Initialize

__init__(element: MacroGroupProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string