Skip to content

FaceStyleProperties

Canonical path: NemAll_Python_BasisElements.FaceStyleProperties

Properties of the style area

Methods:

Attributes:

  • DirectionToReferenceLine (None) –

    Index of the edge of the outline polyline, to align the style area to, when the property UseDirectionToReferenceLine is set to True.

  • FaceStyleID (None) –

    ID of style area

  • ReferencePoint (None) –

    the point of origin, when property UseReferencePoint is set to True

  • RotationAngle (None) –

    Rotation angle

  • UseDirectionToReferenceLine (None) –

    Whether to align the direction of the style area to a certain edge.

  • UseReferencePoint (None) –

    Whether to use a specific point as the origin of the style area.

DirectionToReferenceLine property

DirectionToReferenceLine: None

Index of the edge of the outline polyline, to align the style area to, when the property UseDirectionToReferenceLine is set to True.

FaceStyleID property

FaceStyleID: None

ID of style area

ReferencePoint property

ReferencePoint: None

the point of origin, when property UseReferencePoint is set to True

RotationAngle property

RotationAngle: None

Rotation angle

UseDirectionToReferenceLine property

UseDirectionToReferenceLine: None

Whether to align the direction of the style area to a certain edge.

When set to true, the index of the edge is to be specified in the property DirectionToReferenceLine.

UseReferencePoint property

UseReferencePoint: None

Whether to use a specific point as the origin of the style area.

When set to False, the origin is (0,0). When set to True, the point is to be specified in the property ReferencePoint.

__eq__

__eq__(prop: FaceStyleProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string