Skip to content

RoomElement

Canonical path: NemAll_Python_ArchElements.RoomElement

Bases: ArchElement, AllplanElement

Implementation of the Room element

Methods:

Attributes:

Properties property writable

Properties: RoomProperties

Get the Room properties

GetProperties

GetProperties() -> RoomProperties

Get the Room properties

Returns:

SetCommonProperties

SetCommonProperties(commonProp: CommonProperties)

Set the common properties

Parameters:

SetProperties

SetProperties(RoomProp: RoomProperties)

Set the Room properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(RoomProp: RoomProperties, RoomPolygon: Polygon2D)

Constructor

Parameters:

__init__(element: RoomElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string