Skip to content

BRep3DList

Canonical path: NemAll_Python_Geometry.BRep3DList

List for BRep3D objects

Methods:

  • __contains__

    Check for a value in the list

  • __delitem__

    Delete a list item

  • __eq__

    Compare two lists

  • __getitem__

    Get a list item

  • __iadd__

    Add a list

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __iter__

    List iterator

  • __len__

    Get the list length

  • __repr__

    Create a string from the elements of the list

  • __setitem__

    Set a list item

  • append

    Append a list item

  • extend

    dummy, is only needed for the creation of the documentation by MkDocs

__contains__

__contains__(value: BRep3D) -> bool

Check for a value in the list

Parameters:

  • value (BRep3D) –

    Value to check

Returns:

  • bool

    State for value is in the list

__delitem__

__delitem__(value: BRep3D)

Delete a list item

Parameters:

  • value (BRep3D) –

    Value to delete

__eq__

__eq__(compare_list: BRep3DList) -> bool

Compare two lists

Parameters:

Returns:

  • bool

    Lists are equal state

__getitem__

__getitem__(index: int) -> BRep3D

Get a list item

Parameters:

  • index (int) –

    Index of the item

Returns:

  • BRep3D

    Value for the index

__iadd__

__iadd__(eleList: list) -> BRep3DList

Add a list

Parameters:

  • eleList (list) –

    BRep3D list

Returns:

__init__ overloaded

__init__()

Initialize

__init__(ele: BRep3D)

Constructor with a BRep3D

Parameters:

__init__(eleList: list)

Constructor with a list of BRep3D

Parameters:

  • eleList (list) –

    BRep3D list

__iter__

__iter__() -> Iterator

List iterator

Returns:

  • Iterator

    List iterator

__len__

__len__() -> int

Get the list length

Returns:

  • int

    Length of the list

__repr__

__repr__() -> str

Create a string from the elements of the list

__setitem__

__setitem__(index: int | slice, value: BRep3D)

Set a list item

Parameters:

  • index (int | slice) –

    Index of the item

  • value (BRep3D) –

    Value to item

append

append(value: BRep3D)

Append a list item

Parameters:

  • value (BRep3D) –

    Value to append

extend overloaded

extend(iterable: BRep3DList)

Add the items from an iterable to the end of the list

Parameters:

extend(eleList: list)

Extend the list

Parameters:

  • eleList (list) –

    BRep3D list