Skip to content

PolygonInput

Canonical path: NemAll_Python_IFW_Input.PolygonInput

Bases: CoordinateInput, InputViewDocumentData

Implementation of the polygon input

Methods:

ExecuteInput

ExecuteInput(mouseMsg: int, pnt: Point2D, pMsgInfo: AddMsgInfo) -> int

Execute the input

Parameters:

  • mouseMsg (int) –

    Mouse message

  • pnt (Point2D) –

    View input point

  • pMsgInfo (AddMsgInfo) –

    Additional message info

Returns:

  • int

    execution state

GetPolygon

GetPolygon() -> Polygon3D

get the final polygon

Returns:

GetPreviewPolygon

GetPreviewPolygon() -> Polygon3D

get the preview polygon

Returns:

StartNewInput

StartNewInput()

Start new input

__init__

__init__(coordInput: CoordinateInput, bZCoord: bool, multiPolygon: bool)

Default constructor

After constructing the object, the polygon input toolbar is shown in the Allplan UI

Parameters:

  • coordInput (CoordinateInput) –

    Coordinate input object

  • bZCoord (bool) –

    True will show the Z-coordinate input control, False will hide it.

  • multiPolygon (bool) –

    True allows the user to input a polygon consisting of multiple components. Also negative components (openings) are be allowed. False allows to enter only one polygon component.