Skip to content

VerticalElementProperties

Canonical path: NemAll_Python_ArchElements.VerticalElementProperties

Bases: ArchBaseProperties

Base class representing properties of vertical architectural components, such as columns.

Methods:

Attributes:

Angle property writable

Angle: Angle

Get the angle

Depth property writable

Depth: float

Get the depth

ProfileFullName property writable

ProfileFullName: str

Get the full name of the profile

Radius property writable

Radius: float

Get the radius

ShapePolygon property writable

ShapePolygon: Polygon2D

Get the shape polygon

ShapeType property writable

ShapeType: ShapeType

Get the shape type

Width property writable

Width: float

Get the width

GetAngle

GetAngle() -> Angle

Get the angle

Returns:

GetDepth

GetDepth() -> float

Get the depth

Returns:

  • float

    Depth

GetProfileFullName

GetProfileFullName() -> str

Get the full name of the profile

Returns:

  • str

    Path and name of the profile

GetRadius

GetRadius() -> float

Get the radius

Returns:

  • float

    Radius

GetShapePolygon

GetShapePolygon() -> Polygon2D

Get the shape polygon

Returns:

GetShapeType

GetShapeType() -> ShapeType

Get the shape type

Returns:

GetWidth

GetWidth() -> float

Get the width

Returns:

  • float

    Width

SetAngle

SetAngle(angle: Angle)

Set the angle

Parameters:

  • angle (Angle) –

    Angle

SetAttribute

SetAttribute(attrib: object)

Set the attribute

Parameters:

  • attrib (object) –

    Attribute

SetCornerRadius

SetCornerRadius(radius: float)

Set the corner radius

Parameters:

  • radius (float) –

    Corner radius

SetDepth

SetDepth(depth: float)

Set the depth

Parameters:

  • depth (float) –

    Depth

SetProfileFullName

SetProfileFullName(fullName: str)

Set the full name of the profile

Parameters:

  • fullName (str) –

    Path and name of the profile

SetRadius

SetRadius(radius: float)

Set the radius

Parameters:

  • radius (float) –

    Radius

SetShapePolygon

SetShapePolygon(shapePol: Polygon2D)

Set the shape polygon

Parameters:

SetShapeType

SetShapeType(shapeType: ShapeType)

Set the type of the shape

Parameters:

SetSize

SetSize(width: float, depth: float)

Set the size of the element

Parameters:

  • width (float) –

    Width

  • depth (float) –

    Depth

SetWidth

SetWidth(width: float)

Set the width

Parameters:

  • width (float) –

    Width

__init__

__init__(element: VerticalElementProperties)

Copy constructor

Parameters: