Skip to content

SectionAlongPathScaleProperties

Canonical path: NemAll_Python_BasisElements.SectionAlongPathScaleProperties

Scale properties

Methods:

Attributes:

  • ScaleFactorX (float) –

    Get the resizing factor X in Longitudinal direction

  • ScaleFactorY (float) –

    Get the resizing factor Y in Transversal direction

ScaleFactorX property writable

ScaleFactorX: float

Get the resizing factor X in Longitudinal direction

ScaleFactorY property writable

ScaleFactorY: float

Get the resizing factor Y in Transversal direction

GetScaleFactorTolerance staticmethod

GetScaleFactorTolerance() -> float

Access tolerance

Returns:

  • float

    scale factor tolerance

__init__ overloaded

__init__(bInitFromSTW: bool = False)

constructor

Parameters:

  • bInitFromSTW (bool, default: False ) –
    • is structure initialized from standard values

copy constructor

Parameters: