Skip to content

PatternCurveProperties

Canonical path: NemAll_Python_BasisElements.PatternCurveProperties

PatternCurveProperties class

Methods:

Attributes:

AlignmentType property

AlignmentType: None

the position of the pattern relative to the reference curve

Height property

Height: None

Property for height of pattern

:type: None

IntersectionType property

IntersectionType: None

Property for intersection type

:type: None

IsDrawReferenceCurve property

IsDrawReferenceCurve: None

Whether to draw the reference curve

IsLockedToCorner property

IsLockedToCorner: None

Whether to lock the corner

IsMirrorPattern property

IsMirrorPattern: None

Whether to mirror the pattern

IsScaleDependent property

IsScaleDependent: None

Whether the pattern is to be scale dependent

PatternID property

PatternID: None

Property for pattern ID

:type: None

Width property

Width: None

Property for width of pattern

:type: None

__eq__

__eq__(prop: PatternCurveProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string