Skip to content

ConicalSurface3D

Canonical path: NemAll_Python_Geometry.ConicalSurface3D

3D conical surface

Methods:

  • Get

    Get all surface members

  • GetPlacement

    returns axis placement of the conical surface

  • GetRadius

    Returns the radius at the placement

  • GetSemiAngle

    Returns the value of semi angle of conical surface

  • IsValid

    Check surface validity

  • Set

    Set all surface members

  • SetPlacement

    sets the position of conical surface

  • SetRadius

    Sets the radius at the placement

  • SetSemiAngle

    Sets the value of semi angle of conical surface

  • __eq__

    Comparison of conical surfaces without tolerance.

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

  • __repr__

    Convert the list to a string

Attributes:

  • Placement (None) –

    Get and set the placement property

  • Radius (None) –

    Get and set the radius property

  • SemiAngle (None) –

    Get and set the semi angle property

Placement property

Placement: None

Get and set the placement property

:type: None

Radius property

Radius: None

Get and set the radius property

:type: None

SemiAngle property

SemiAngle: None

Get and set the semi angle property

:type: None

Get

Get() -> tuple

Get all surface members

Returns:

  • tuple

    placement of conical surface,

  • tuple

    radius of conical surface in placement,

  • tuple

    semi angle of conical surface

GetPlacement

GetPlacement() -> AxisPlacement3D

returns axis placement of the conical surface

Returns:

  • AxisPlacement3D

    placement - point + axis vector + reference direction vector

GetRadius

GetRadius() -> float

Returns the radius at the placement

Returns:

  • float

    radius

GetSemiAngle

GetSemiAngle() -> Angle

Returns the value of semi angle of conical surface

Returns:

IsValid

IsValid() -> bool

Check surface validity

Returns:

  • bool

    bool valid = true

Set

Set(placement: AxisPlacement3D, radius: float, angle: Angle)

Set all surface members

Parameters:

  • placement (AxisPlacement3D) –

    placement of conical surface

  • radius (float) –

    radius of conical surface in placement

  • angle (Angle) –

    semi angle of conical surface

SetPlacement

SetPlacement(value: AxisPlacement3D)

sets the position of conical surface

Parameters:

  • value (AxisPlacement3D) –

    placement - point + axis vector + reference direction vector

SetRadius

SetRadius(value: float)

Sets the radius at the placement

Parameters:

  • value (float) –

    radius to be set

SetSemiAngle

SetSemiAngle(value: Angle)

Sets the value of semi angle of conical surface

Parameters:

  • value (Angle) –

    angle to be set

__eq__

__eq__(surface: ConicalSurface3D) -> object

Comparison of conical surfaces without tolerance.

Be careful, this method work without tolerance!

Parameters:

  • conical

    surface Compared conical surface.

Returns:

  • object

    True when conical surfaces are equal, otherwise false.

__init__ overloaded

__init__()

Initialize

__init__(placement: AxisPlacement3D, radius: float, angle: Angle)

Default constructor.

Parameters:

  • placement (AxisPlacement3D) –

    placement of conical surface

  • radius (float) –

    radius at a placement

  • angle (Angle) –

    angle between placement axis and some axis on surface

__init__(surface: ConicalSurface3D)

Copy constructor.

Parameters:

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string