Skip to content

HatchingProperties

Canonical path: NemAll_Python_BasisElements.HatchingProperties

Properties of the hatching

Methods:

Attributes:

  • BackgroundColor (ARGB) –

    Background color. Relevant, when UseBackgroundColor is set to True.

  • DirectionToReferenceLine (int) –

    The edge index of the outline polyline to align the hatching to.

  • ExistAlignment (bool) –

    Whether to align the hatching to a certain edge of the outline polyline. When set to True, the index of the edge is to be specified in DirectionToReferenceLine.

  • HatchID (int) –

    ID of the hatch

  • IsScaleDependent (bool) –

    Whether the hatch is to be scaled according to drawing file scale

  • ReferencePoint (Point2D) –

    the point of origin, when property UseReferencePoint is set to True

  • RotationAngle (Angle) –

    Rotation angle

  • UseBackgroundColor (bool) –

    Whether to use background color

  • UseReferencePoint (bool) –

    Whether to use a specific point as the origin of the hatching.

BackgroundColor property writable

BackgroundColor: ARGB

Background color. Relevant, when UseBackgroundColor is set to True.

DirectionToReferenceLine property writable

DirectionToReferenceLine: int

The edge index of the outline polyline to align the hatching to.

ExistAlignment property writable

ExistAlignment: bool

Whether to align the hatching to a certain edge of the outline polyline. When set to True, the index of the edge is to be specified in DirectionToReferenceLine.

HatchID property writable

HatchID: int

ID of the hatch

IsScaleDependent property writable

IsScaleDependent: bool

Whether the hatch is to be scaled according to drawing file scale

ReferencePoint property writable

ReferencePoint: Point2D

the point of origin, when property UseReferencePoint is set to True

RotationAngle property writable

RotationAngle: Angle

Rotation angle

UseBackgroundColor property writable

UseBackgroundColor: bool

Whether to use background color

UseReferencePoint property writable

UseReferencePoint: bool

Whether to use a specific point as the origin of the hatching.

When set to False, the origin is (0,0). When set to True, the point is to be specified in the property ReferencePoint.

SetBackgroundColorBGR

SetBackgroundColorBGR(value: int)

Set the background color

Parameters:

  • value (int) –

    Color value as BGR

SetBackgroundColorIRGB

SetBackgroundColorIRGB(value: int)

Set the background color

Parameters:

  • value (int) –

    Color value as IRGB

__eq__

__eq__(prop: HatchingProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__ overloaded

__init__()

Initialize

__init__(element: HatchingProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string