Skip to content

DimensionLineElement

Canonical path: NemAll_Python_BasisElements.DimensionLineElement

Bases: BasisElement, AllplanElement

Representation of the dimension line in Allplan.

This class is also a base class for the elevation points.

Methods:

GetDimensionPoints

GetDimensionPoints() -> Point3DList

Get the dimension points

Returns:

GetDirectionVector

GetDirectionVector() -> Vector2D

Get the direction vector

Returns:

GetPlacementVector

GetPlacementVector() -> Vector2D

Get the placement vector

Returns:

__init__ overloaded

__init__()

Initialize

__init__(
    arg2: Point3DList,
    dimensionPoints: Vector2D,
    placementPoint: Vector2D,
    directionVector: DimensionProperties,
)

Constructor

Parameters:

  • dimensionPoints (Vector2D) –

    Dimension points

  • placementVector

    Placement vector to the first dimension point

  • directionVector (DimensionProperties) –

    Direction vector

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string