Skip to content

Matrix3DList

Canonical path: NemAll_Python_Geometry.Matrix3DList

List for Matrix3D objects

Methods:

__contains__

__contains__(value: Matrix3D) -> bool

Check for a value in the list

Parameters:

Returns:

  • bool

    State for value is in the list

__delitem__

__delitem__(value: Matrix3D)

Delete a list item

Parameters:

__eq__

__eq__(compare_list: Matrix3DList) -> bool

Compare two lists

__getitem__

__getitem__(index: int) -> Matrix3D

Get a list item

Parameters:

  • index (int) –

    Index of the item

Returns:

__init__

__init__()

Initialize

__iter__

__iter__() -> Iterator

List iterator

Returns:

  • Iterator

    List iterator

__len__

__len__() -> int

Get the list length

Returns:

  • int

    Length of the list

__repr__

__repr__() -> str

Create a string from the elements of the list

__setitem__

__setitem__(index: int | slice, value: Matrix3D)

Set a list item

Parameters:

  • index (int | slice) –

    Index of the item

  • value (Matrix3D) –

    Value to item

append

append(value: Matrix3D)

Append a list item

Parameters:

extend

extend(iterable: Matrix3DList)

Add the items from an iterable to the end of the list

Parameters: