Skip to content

AxisElementAdapter

Canonical path: NemAll_Python_IFW_ElementAdapter.AxisElementAdapter

Bases: BaseElementAdapter

Implementation of the axis element adapter

Methods:

GetAxis

GetAxis() -> Any

Get wall axis

Returns:

  • Any

    IGeometry2D arbitrary curve pointer

GetGeometry

GetGeometry() -> Any

Get elements geometry

Returns:

  • Any

    Geometry

GetOffset

GetOffset() -> float

Get the element offset from the axis

Returns:

  • float

    Element offset from the axis

GetThickness

GetThickness() -> float

Get the element thickness

Returns:

  • float

    Element thickness

GetTierThickness

GetTierThickness() -> VecDoubleList

Get the thickness of the tiers

Returns:

GetTiersCount

GetTiersCount() -> int

Get the amount of tiers

Returns:

  • int

    number of tiers of this axis element

HasAxis

HasAxis() -> bool

Check, if this element has an axis

Returns:

  • bool

    true, if axis element has an axis

IsElementParallelToAxis

IsElementParallelToAxis() -> bool

Is element direction parallel to axis direction

Returns:

  • bool

    Is element direction parallel to axis direction state

IsNull

IsNull() -> bool

Check for an empty element

Returns:

  • bool

    Element is empty: true/false

__init__ overloaded

__init__()

Initialize

__init__(element: BaseElementAdapter)

Constructor

Parameters:

__init__(element: AxisElementAdapter)

Copy constructor

Parameters: