Skip to content

ArchitectureElementsGeometryService

Canonical path: NemAll_Python_ArchElements.ArchitectureElementsGeometryService

Implementation of the architecture elements geometry service

Methods:

CreatePlacementArc staticmethod

CreatePlacementArc(
    element: BaseElementAdapter,
    elementAxis: Arc2D,
    placementPnt: Point2D,
    directionPnt: Point2D,
) -> tuple[Arc2D, bool]

Create a placement arc at the placement point

Parameters:

Returns:

  • tuple[Arc2D, bool]

    Placement arc, placement a bottom/top (true/false)

GetOpeningOffsetPoints staticmethod

GetOpeningOffsetPoints(
    parentEle: BaseElementAdapter, placementPnt: Point2D
) -> tuple[bool, Point2D, Point2D]

Get the offset points for the opening

Parameters:

Returns:

GetOuterPolyline staticmethod

GetOuterPolyline(
    elementPolygon: Polygon2D, refLine: Line2D, elementAxis: object
) -> Polyline2D

Get the outer polyline from a curved element located at the reference line

Parameters:

  • elementPolygon (Polygon2D) –

    Polygon of the curved element

  • refLine (Line2D) –

    Reference line of the polyline

  • elementAxis (object) –

    Axis of the element

Returns:

GetOutlineSegmentAndPoint staticmethod

GetOutlineSegmentAndPoint(
    element: BaseElementAdapter, refPoint: Point2D
) -> tuple[Line2D, Point2D, BaseElementAdapter]

Get the outline segment and point related to the reference point

Parameters:

Returns: