Skip to content

PlaneReferences

Canonical path: NemAll_Python_ArchElements.PlaneReferences

Bases: BasePlaneReferences

Implementation of the plane references

Classes:

  • Direction

    Definitions of ways, how the offset distance between the reference plane and the top/bottom edge of the architectural component is measured.

  • ElementToPlaneModeling

    Way of modeling of the top edge of an architectural component against the reference plane

  • PlaneReferenceDependency

    Possible dependencies between top/bottom edge of an architectural component and a reference plane

Methods:

Attributes:

AbsBottomElevation property writable

AbsBottomElevation: float

Get the absolute bottom elevation

AbsTopElevation property writable

AbsTopElevation: float

Get the absolute top elevation

BottomDirection property writable

BottomDirection: Direction

Get the bottom direction

BottomElevation property writable

BottomElevation: float

Get the bottom plane elevation relative to the bottom plane of the document

BottomOffset property writable

BottomOffset: float

Offset between the reference plane and the bottom edge of an architectural component.

If the property BottomPlaneDependency is set to eAbsElevation, this is the absolute elevation of the bottom edge.

BottomPlaneDependency property writable

BottomPlaneDependency: PlaneReferenceDependency

Type of dependency of the bottom edge of the architectural component

BottomPlaneSurface property writable

BottomPlaneSurface: Any

Get the bottom plane surface

BottomReferencePlane property writable

BottomReferencePlane: ReferencePlaneID

Get the bottom reference plane

Document property writable

Document: DocumentAdapter

Get the document

Height property writable

Height: float

Get the height

MaximumHeight property writable

MaximumHeight: float

Maximum height of the architectural component measured from its bottom

ReferenceElement property writable

ReferenceElement: BaseElementAdapter

Get the reference element for the plane

TopDirection property writable

TopDirection: Direction

Get the top direction

TopElevation property writable

TopElevation: float

Get the top plane elevation relative to the top plane of the document

TopOffset property writable

TopOffset: float

Offset between the reference plane and the top edge of an architectural component. If the property TopPlaneDependency is set to eAbsElevation, this is the absolute elevation of the top edge.

TopPlaneDependency property writable

TopPlaneDependency: PlaneReferenceDependency

Type of dependency of the top edge of the architectural component

TopPlaneSurface property writable

TopPlaneSurface: Any

Get the top plane surface

TopReferencePlane property writable

TopReferencePlane: ReferencePlaneID

Get the top reference plane

Direction

Canonical path: NemAll_Python_ArchElements.PlaneReferences.Direction

Bases: Enum

Definitions of ways, how the offset distance between the reference plane and the top/bottom edge of the architectural component is measured.

Methods:

Attributes:

  • eOrthogonal

    The offset distance is measured vertically, along the global Z axis

  • eParallel

    The offset distance is measured perpendicular to the reference plane

eOrthogonal class-attribute instance-attribute

eOrthogonal = 1

The offset distance is measured vertically, along the global Z axis

eParallel class-attribute instance-attribute

eParallel = 0

The offset distance is measured perpendicular to the reference plane

__getitem__

__getitem__(key: str | int | float) -> Direction

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

ElementToPlaneModeling

Canonical path: NemAll_Python_ArchElements.PlaneReferences.ElementToPlaneModeling

Bases: Enum

Way of modeling of the top edge of an architectural component against the reference plane

Methods:

Attributes:

  • eFitToPlane

    Standard adaptation - element takes the shape of the reference plane

  • eLowerCutToPlane

    Jamb wall adaptation - element is cut horizontally below the plane

  • eUpperCutToPlane

    Chimney adaptation - element is cut horizontally above the plane

eFitToPlane class-attribute instance-attribute

eFitToPlane = 0

Standard adaptation - element takes the shape of the reference plane

eLowerCutToPlane class-attribute instance-attribute

eLowerCutToPlane = 1

Jamb wall adaptation - element is cut horizontally below the plane

eUpperCutToPlane class-attribute instance-attribute

eUpperCutToPlane = 2

Chimney adaptation - element is cut horizontally above the plane

__getitem__

__getitem__(key: str | int | float) -> ElementToPlaneModeling

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

PlaneReferenceDependency

Canonical path: NemAll_Python_ArchElements.PlaneReferences.PlaneReferenceDependency

Bases: Enum

Possible dependencies between top/bottom edge of an architectural component and a reference plane

Methods:

Attributes:

eAbsElevation class-attribute instance-attribute

eAbsElevation = 0

Absolute elevation

eBottomFixed class-attribute instance-attribute

eBottomFixed = 6

Fixed to lower reference plane

eBottomPlane class-attribute instance-attribute

eBottomPlane = 1

Relative to lower reference plane

eComponentsBottomPlane class-attribute instance-attribute

eComponentsBottomPlane = 3

Relative to bottom edge of another architectural component

eComponentsTopPlane class-attribute instance-attribute

eComponentsTopPlane = 4

Relative to top edge of another architectural component

eTopFixed class-attribute instance-attribute

eTopFixed = 5

Fixed to top reference plane

eTopPlane class-attribute instance-attribute

eTopPlane = 2

Relative to upper reference plane

__getitem__

__getitem__(key: str | int | float) -> PlaneReferenceDependency

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

GetAbsBottomElevation

GetAbsBottomElevation() -> float

Get the absolute bottom elevation

Returns:

  • float

    Absolute bottom elevation

GetAbsTopElevation

GetAbsTopElevation() -> float

Get the absolute top elevation

Returns:

  • float

    Absolute top elevation

GetBottomDirection

GetBottomDirection() -> Direction

Get the bottom direction

Returns:

GetBottomElevation

GetBottomElevation() -> float

Get the bottom plane elevation relative to the bottom plane of the document

Returns:

  • float

    Bottom plane elevation

GetBottomOffset

GetBottomOffset() -> float

Get the offset relative to the defined plane for the bottom

Returns:

  • float

    Offset relative to the defined plane for the bottom

GetBottomPlaneDependency

GetBottomPlaneDependency() -> PlaneReferenceDependency

Get the bottom plane dependency

Returns:

GetBottomPlaneSurface

GetBottomPlaneSurface() -> Any

Get the bottom plane surface

Returns:

  • Any

    Bottom plane surface

GetBottomReferencePlane

GetBottomReferencePlane() -> ReferencePlaneID

Get the bottom reference plane

Returns:

GetDocument

GetDocument() -> DocumentAdapter

Get the document

Returns:

GetHeight

GetHeight() -> float

Get the height

Returns:

  • float

    Height

GetMaximumHeight

GetMaximumHeight() -> float

Get the maximum height

Returns:

  • float

    Maximum height

GetReferenceElement

GetReferenceElement() -> BaseElementAdapter

Get the reference element for the plane

GetTopDirection

GetTopDirection() -> Direction

Get the top direction

Returns:

GetTopElevation

GetTopElevation() -> float

Get the top plane elevation relative to the top plane of the document

Returns:

  • float

    Top plane elevation

GetTopOffset

GetTopOffset() -> float

Get the offset relative to the defined plane for the top

Returns:

  • float

    Offset relative to the defined plane for the top

GetTopPlaneDependency

GetTopPlaneDependency() -> PlaneReferenceDependency

Get the top plane dependency

Returns:

GetTopPlaneSurface

GetTopPlaneSurface() -> Any

Get the top plane surface

Returns:

  • Any

    Top plane surface

GetTopReferencePlane

GetTopReferencePlane() -> ReferencePlaneID

Get the top reference plane

Returns:

SetAbsBottomElevation

SetAbsBottomElevation(absElevation: float)

Set the absolute bottom elevation

Parameters:

  • absElevation (float) –

    Absolute bottom elevation

SetAbsTopElevation

SetAbsTopElevation(absElevation: float)

Set the absolute top elevation

Parameters:

  • absElevation (float) –

    Absolute top elevation

SetBottomDirection

SetBottomDirection(direction: Direction)

Set the bottom plane Direction

Parameters:

SetBottomElevation

SetBottomElevation(elevation: float)

Set the bottom plane elevation relative to the bottom plane of the document

Parameters:

  • elevation (float) –

    Elevation

SetBottomOffset

SetBottomOffset(offset: float)

Set the offset relative to the defined plane for the bottom

Parameters:

  • offset (float) –

    Offset relative to the defined plane for the bottom

SetBottomPlaneDependency

SetBottomPlaneDependency(dependency: PlaneReferenceDependency)

Set the bottom plane dependency

Parameters:

SetBottomPlaneSurface

SetBottomPlaneSurface(bottomSurface: object)

Set the bottom plane surface

Parameters:

  • bottomSurface (object) –

    Bottom plane surface

SetBottomReferencePlane

SetBottomReferencePlane(bottomReferencePlane: ReferencePlaneID)

Set the bottom reference plane

Parameters:

SetBottomSurfacePlaneElement

SetBottomSurfacePlaneElement(surfacePlane: BaseElementAdapter)

Set the bottom surface plane

Parameters:

SetBottomToBottom

SetBottomToBottom(planeRef: PlaneReferences)

Set the bottom level to the bottom level of the source plane reference

Parameters:

SetBottomToTop

SetBottomToTop(planeRef: PlaneReferences)

Set the bottom level to the top level of the source plane reference

Parameters:

SetDocument

SetDocument(doc: DocumentAdapter)

Set the document

Parameters:

SetElementToPlaneModeling

SetElementToPlaneModeling(elementToPlaneModeling: ElementToPlaneModeling)

Set the way of modeling the top edge of an architectural component against the reference plane

Parameters:

  • elementToPlaneModeling (ElementToPlaneModeling) –

    Way of modeling the top edge against the reference plane

SetHeight

SetHeight(height: float)

Set the height

Parameters:

  • height (float) –

    Height

SetMaximumHeight

SetMaximumHeight(maximumHeight: float)

Set maximum height

Parameters:

  • maximumHeight (float) –

    double

SetReferenceElement

SetReferenceElement(refElement: BaseElementAdapter)

Set the reference element for the plane

Parameters:

SetTopDirection

SetTopDirection(direction: Direction)

Set the top plane Direction

Parameters:

SetTopElevation

SetTopElevation(elevation: float)

Set the top plane elevation relative to the top plane of the document

Parameters:

  • elevation (float) –

    Elevation

SetTopOffset

SetTopOffset(offset: float)

Set the offset relative to the defined plane for the top

Parameters:

  • offset (float) –

    Offset relative to the defined plane for the top

SetTopPlaneDependency

SetTopPlaneDependency(dependency: PlaneReferenceDependency)

Set the top plane dependency

Parameters:

SetTopPlaneSurface

SetTopPlaneSurface(topPlaneSurface: object)

Set the top plane surface

Parameters:

  • topPlaneSurface (object) –

    Top plane surface

SetTopReferencePlane

SetTopReferencePlane(topReferencePlane: ReferencePlaneID)

Set the top reference plane

Parameters:

SetTopSurfacePlaneElement

SetTopSurfacePlaneElement(surfacePlane: BaseElementAdapter)

Set the top surface plane

Parameters:

SetTopToBottom

SetTopToBottom(planeRef: PlaneReferences)

Set the top level to the bottom level of the source plane reference

Parameters:

SetTopToTop

SetTopToTop(planeRef: PlaneReferences)

Set the top level to the top level of the source plane reference

Parameters:

__init__ overloaded

__init__(doc: DocumentAdapter, refElement: BaseElementAdapter)

Constructor

Parameters:

__init__(element: PlaneReferences)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string