Skip to content

StructuralBeamProperties

Canonical path: NemAll_Python_ArchElements.StructuralBeamProperties

Bases: StructuralElementProperties, ArchBaseProperties

Representation of the properties of the structural framing beam

Methods:

GetEndPoint

GetEndPoint() -> Point3D

Get the end point of the element in world coordinate system

Returns:

GetStartPoint

GetStartPoint() -> Point3D

Get the start point of the element in world coordinate system

Returns:

SetAnchorPointProperties

SetAnchorPointProperties(
    anchorPointStart: int,
    offsetStart: Point2D,
    anchorPointEnd: int,
    offsetEnd: Point2D,
    twoAnchorPoints: bool,
)

Set the properties of the beam anchor points

Parameters:

  • anchorPointStart (int) –

    anchor point position

  • offsetStart (Point2D) –

    offset from start anchor point

  • anchorPointEnd (int) –

    anchor point position

  • offsetEnd (Point2D) –

    offset from end anchor point

  • twoAnchorPoints (bool) –

    true when both anchor points are used

SetEndPoint

SetEndPoint(x: float, y: float, z: float)

Set the end point of the element in world coordinate system

Parameters:

  • x (float) –

    x coordinate

  • y (float) –

    y coordinate

  • z (float) –

    z coordinate

SetHeightProperties

SetHeightProperties(doc: DocumentAdapter, planeReferences: PlaneReferences)

Set height properties

Parameters:

SetHeightPropsByPlacementPoints

SetHeightPropsByPlacementPoints(
    doc: DocumentAdapter,
    value: PlaneReferences,
    startPointZcoord: float,
    endPointZcoord: float,
)

Set HeightProperties by the placement points

Parameters:

  • doc (DocumentAdapter) –

    Document

  • value (PlaneReferences) –

    Height properties

  • startPointZcoord (float) –

    Z coordinate of the start point

  • endPointZcoord (float) –

    Z coordinate of the end point

SetStartPoint

SetStartPoint(x: float, y: float, z: float)

Set the start point of the element in world coordinate system

Parameters:

  • x (float) –

    x coordinate

  • y (float) –

    y coordinate

  • z (float) –

    z coordinate

__init__ overloaded

__init__()

Initialize

__init__(value: StructuralBeamProperties)

Constructor

Parameters: