Skip to content

ReinforcementSettings

Canonical path: NemAll_Python_Reinforcement.ReinforcementSettings

Methods:

CheckBarDiameter staticmethod

CheckBarDiameter() -> float

Check, whether the diameter is included in the diameter list of the current steel grade

Returns:

  • float

    Bar diameter (original or nearest value)

CheckMeshGroup staticmethod

CheckMeshGroup() -> int

Check, whether the mesh group is included in the group list

Returns:

  • int

    Mesh group (original or first)

GetBarDiameter staticmethod

GetBarDiameter() -> float

Get the current bar diameter

Returns:

  • float

    Bar diameter

GetBarWeight staticmethod

GetBarWeight(steelGrade: int, barDiameter: float) -> float

Get the weight for a bar diameter

Parameters:

  • steelGrade (int) –

    Steel grade

  • barDiameter (float) –

    Bar diameter

Returns:

  • float

    Weight for a bar diameter

GetBendingRoller staticmethod

GetBendingRoller() -> float

Get the current bending roller

Returns:

  • float

    Bending roller

GetConcreteGrade staticmethod

GetConcreteGrade() -> int

Get the current concrete grade

Returns:

  • int

    Concrete grade

GetMaxBarLength staticmethod

GetMaxBarLength() -> float

Get the maximal bar length

Returns:

  • float

    Maximal bar length

GetMeshGroup staticmethod

GetMeshGroup() -> int

Get the current mesh group

Returns:

  • int

    Mesh group

GetMeshType staticmethod

GetMeshType() -> str

Get the current mesh type

Returns:

  • str

    Mesh type

GetNorm staticmethod

GetNorm() -> int

Get the current norm

Returns:

  • int

    Norm

GetSteelGrade staticmethod

GetSteelGrade() -> int

Get the current steel grade

Returns:

  • int

    Steel grade

Is3DReinforcement staticmethod

Is3DReinforcement() -> bool

Get the 3D-Reinforcement state

Returns:

  • bool

    Create 3D-Reinforcement: true/false

__init__

__init__()

Initialize