Skip to content

AssocViewElementAdapter

Canonical path: NemAll_Python_IFW_ElementAdapter.AssocViewElementAdapter

Bases: BaseElementAdapter

Methods:

  • GetTransformationMatrix

    Get the transformation matrix of the associative view

  • IsNull

    Check for an empty element

  • __init__

    dummy, is only needed for the creation of the documentation by MkDocs

GetTransformationMatrix

GetTransformationMatrix() -> Matrix3D

Get the transformation matrix of the associative view

Returns:

  • Matrix3D

    Transformation matrix of the associative view

IsNull

IsNull() -> bool

Check for an empty element

Returns:

  • bool

    Element is empty: true/false

__init__ overloaded

__init__()

Initialize

__init__()

Constructor

__init__(ele: BaseElementAdapter)

Constructor

Parameters: