Skip to content

VisibleHiddenEdgesProperties

Canonical path: NemAll_Python_BasisElements.VisibleHiddenEdgesProperties

Properties of the visible and hidden edges in a UVS

Methods:

Attributes:

  • HiddenEdgesColor (None) –

    Color ID of hidden edges

  • HiddenEdgesLayer (None) –

    layer ID for hidden edges

  • HiddenEdgesLineType (None) –

    stroke ID for hidden edges

  • HiddenEdgesPen (None) –

    pen ID for hidden edges

  • IsHiddenEdgesColorFromLayer (None) –

    Whether to get the color ID of the hidden edges from the layer definition

  • IsHiddenEdgesColorUsed (None) –

    Whether to use the color specified in HiddenEdgesColor for drawing the hidden edges (True) or the color of the model elements (False)

  • IsHiddenEdgesLayerUsed (None) –

    Whether to use the layer specified in HiddenEdgesLayer for drawing the hidden edges (True) or the layer of the model elements (False)

  • IsHiddenEdgesLineTypeFromLayer (None) –

    Whether to get the stroke ID of the hidden edges from the layer definition

  • IsHiddenEdgesLineTypeUsed (None) –

    Whether to use the stroke specified in HiddenEdgesLineType for drawing the hidden edges (True) or the stroke of the model elements (False)

  • IsHiddenEdgesOn (None) –

    Whether to draw hidden edges

  • IsHiddenEdgesPenFromLayer (None) –

    Whether to get the pen ID of the hidden edges from the layer definition

  • IsHiddenEdgesPenUsed (None) –

    Whether to use the pen specified in HiddenEdgesPen for drawing the hidden edges (True) or the pen of the model elements (False)

  • IsVisibleEdgesColorFromLayer (None) –

    Whether to get the color ID of the visible edges from the layer definition

  • IsVisibleEdgesColorUsed (None) –

    Whether to use the color specified in VisibleEdgesColor for drawing the visible edges (True) or the color of the model elements (False)

  • IsVisibleEdgesLayerUsed (None) –

    Whether to use the layer specified in VisibleEdgesLayer for drawing the visible edges (True) or the layer of the model elements (False)

  • IsVisibleEdgesLineTypeFromLayer (None) –

    Whether to get the stroke ID of the visible edges from the layer definition

  • IsVisibleEdgesLineTypeUsed (None) –

    Whether to use the stroke specified in VisibleEdgesLineType for drawing the visible edges (True) or the stroke of the model elements (False)

  • IsVisibleEdgesOn (None) –

    Whether to draw visible edges

  • IsVisibleEdgesPenFromLayer (None) –

    Whether to get the pen ID of the visible edges from the layer definition

  • IsVisibleEdgesPenUsed (None) –

    Whether to use the pen specified in VisibleEdgesPen for drawing the visible edges (True) or the pen of the model elements (False)

  • VisibleEdgesColor (None) –

    Color ID for visible edges

  • VisibleEdgesLayer (None) –

    Layer ID for visible edges

  • VisibleEdgesLineType (None) –

    Stroke ID for visible edges

  • VisibleEdgesPen (None) –

    Pen ID for visible edges

HiddenEdgesColor property

HiddenEdgesColor: None

Color ID of hidden edges

HiddenEdgesLayer property

HiddenEdgesLayer: None

layer ID for hidden edges

HiddenEdgesLineType property

HiddenEdgesLineType: None

stroke ID for hidden edges

HiddenEdgesPen property

HiddenEdgesPen: None

pen ID for hidden edges

IsHiddenEdgesColorFromLayer property

IsHiddenEdgesColorFromLayer: None

Whether to get the color ID of the hidden edges from the layer definition

IsHiddenEdgesColorUsed property

IsHiddenEdgesColorUsed: None

Whether to use the color specified in HiddenEdgesColor for drawing the hidden edges (True) or the color of the model elements (False)

IsHiddenEdgesLayerUsed property

IsHiddenEdgesLayerUsed: None

Whether to use the layer specified in HiddenEdgesLayer for drawing the hidden edges (True) or the layer of the model elements (False)

IsHiddenEdgesLineTypeFromLayer property

IsHiddenEdgesLineTypeFromLayer: None

Whether to get the stroke ID of the hidden edges from the layer definition

IsHiddenEdgesLineTypeUsed property

IsHiddenEdgesLineTypeUsed: None

Whether to use the stroke specified in HiddenEdgesLineType for drawing the hidden edges (True) or the stroke of the model elements (False)

IsHiddenEdgesOn property

IsHiddenEdgesOn: None

Whether to draw hidden edges

IsHiddenEdgesPenFromLayer property

IsHiddenEdgesPenFromLayer: None

Whether to get the pen ID of the hidden edges from the layer definition

IsHiddenEdgesPenUsed property

IsHiddenEdgesPenUsed: None

Whether to use the pen specified in HiddenEdgesPen for drawing the hidden edges (True) or the pen of the model elements (False)

IsVisibleEdgesColorFromLayer property

IsVisibleEdgesColorFromLayer: None

Whether to get the color ID of the visible edges from the layer definition

IsVisibleEdgesColorUsed property

IsVisibleEdgesColorUsed: None

Whether to use the color specified in VisibleEdgesColor for drawing the visible edges (True) or the color of the model elements (False)

IsVisibleEdgesLayerUsed property

IsVisibleEdgesLayerUsed: None

Whether to use the layer specified in VisibleEdgesLayer for drawing the visible edges (True) or the layer of the model elements (False)

IsVisibleEdgesLineTypeFromLayer property

IsVisibleEdgesLineTypeFromLayer: None

Whether to get the stroke ID of the visible edges from the layer definition

IsVisibleEdgesLineTypeUsed property

IsVisibleEdgesLineTypeUsed: None

Whether to use the stroke specified in VisibleEdgesLineType for drawing the visible edges (True) or the stroke of the model elements (False)

IsVisibleEdgesOn property

IsVisibleEdgesOn: None

Whether to draw visible edges

IsVisibleEdgesPenFromLayer property

IsVisibleEdgesPenFromLayer: None

Whether to get the pen ID of the visible edges from the layer definition

IsVisibleEdgesPenUsed property

IsVisibleEdgesPenUsed: None

Whether to use the pen specified in VisibleEdgesPen for drawing the visible edges (True) or the pen of the model elements (False)

VisibleEdgesColor property

VisibleEdgesColor: None

Color ID for visible edges

VisibleEdgesLayer property

VisibleEdgesLayer: None

Layer ID for visible edges

VisibleEdgesLineType property

VisibleEdgesLineType: None

Stroke ID for visible edges

VisibleEdgesPen property

VisibleEdgesPen: None

Pen ID for visible edges

__init__

__init__()

Initialize