Skip to content

FixtureProperties

Canonical path: NemAll_Python_Precast.FixtureProperties

FixtureProperties class

Methods:

Attributes:

CatalogName property

CatalogName: None

Value type: str

:type: None

DomainType property

DomainType: None

Domaintype of the Fixture element

Value type: None

:type: None

InsertionPoint property

InsertionPoint: None

Value type: Point3D

:type: None

IsScaleDependent property

IsScaleDependent: None

Value type: bool

:type: None

Name property

Name: None

Value type: str

:type: None

PositionNr property

PositionNr: None

Value type: int

:type: None

SubType property

SubType: None

SubType of the Fixture element

Value type: MacroSubType

:type: None

Type property

Type: None

Type of the Fixture element

Value type: MacroType

:type: None

UnitFactor property

UnitFactor: None

Value type: int

:type: None

__eq__

__eq__(prop: FixtureProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string