Skip to content

AssociativeViewElement

Canonical path: NemAll_Python_BasisElements.AssociativeViewElement

Bases: AllplanElement

Representation of the associative views and sections

WARNING!!: Associative views and sections are deprecated and not supported in Allplan >=2023! Use UVSs instead (represented by ViewSectionElement class)

Methods:

Attributes:

ClippingPathProperties property

ClippingPathProperties: None

Property for the clipping path properties

:type: None

DimensionElements property

DimensionElements: None

Property for the dimension elements

:type: None

PlacementAngle property

PlacementAngle: None

Property for the placement angle

:type: None

PlacementPoint property

PlacementPoint: None

Property for the placement point

:type: None

ReinforcementLabels property

ReinforcementLabels: None

Property for the reinforcement labels

:type: None

SectionAngle property

SectionAngle: None

Property for the section angle

:type: None

SectionPolyhedron property

SectionPolyhedron: None

Property for the section polyhedron

:type: None

TextElements property

TextElements: None

Property for the text elements

:type: None

ViewMatrix property

ViewMatrix: None

Property for the view matrix

:type: None

ViewProperties property

ViewProperties: None

Property for the view properties

:type: None

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string