Skip to content

AxisProperties

Canonical path: NemAll_Python_ArchElements.AxisProperties

Properties of architectural axis.

These settings apply to linear architectural components defined by a horizontal axis, such as walls or beams.

Methods:

Attributes:

  • Distance (float) –

    Offset distance between the axis and the outer side of the architectural component

  • Extension (int) –

    Defines, on which side of the axis the architectural component (or its tiers) is created.

  • Modus (int) –

    Get the modus

  • OnTier (int) –

    In case of a multilayer wall, the index of the tier, to which the axis should refer

  • Position (int) –

    Position of the axis relative to the architectural component

Distance property writable

Distance: float

Offset distance between the axis and the outer side of the architectural component

Extension property writable

Extension: int

Defines, on which side of the axis the architectural component (or its tiers) is created. Assuming the axis points in the X+ direction, setting the value to:

  • 1 will result in the architectural component being drawn above the axis
  • -1 will result in the architectural component being drawn below the axis and in case of a wall, the tiers being mirrored

Modus property writable

Modus: int

Get the modus

OnTier property writable

OnTier: int

In case of a multilayer wall, the index of the tier, to which the axis should refer

Position property writable

Position: int

Position of the axis relative to the architectural component

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string