Skip to content

VerticalOpeningTierOffsetProperties

Canonical path: NemAll_Python_ArchElements.VerticalOpeningTierOffsetProperties

Implementation of the vertical opening tier offset properties

Methods:

Attributes:

BottomOffset property writable

BottomOffset: float

Get the bottom offset

BottomOffsets property writable

BottomOffsets: list[float]

Get the bottom offsets

LeftOffset property writable

LeftOffset: float

Get the left offset

LeftOffsets property writable

LeftOffsets: list[float]

Get the left offset

RightOffset property writable

RightOffset: float

Get the right offset

RightOffsets property writable

RightOffsets: list[float]

Get the right offsets

TopOffset property writable

TopOffset: float

Get the top offset

TopOffsets property writable

TopOffsets: list[float]

Get the top offsets

Type property writable

Get the tier offset type

GetFacingProperties

GetFacingProperties() -> VerticalOpeningFacingProperties

Get the facing properties

Returns:

__init__

Copy constructor

Parameters: