Skip to content

SelectElementsService

Canonical path: NemAll_Python_IFW_Input.SelectElementsService

Classes:

Methods:

eSelectCondition

Canonical path: NemAll_Python_IFW_Input.SelectElementsService.eSelectCondition

Bases: Enum

Element selection condition

Methods:

__getitem__

__getitem__(key: str | int | float) -> eSelectCondition

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

SelectByPolygon staticmethod

SelectByPolygon(
    doc: DocumentAdapter,
    polygon: Polygon2D,
    viewProjection: ViewWorldProjection,
    selCond: eSelectCondition,
    filter: SelectionQuery,
    isWorldPolygon: bool = False,
) -> BaseElementAdapterList

Select an element by a point

Parameters:

  • doc (DocumentAdapter) –

    Document

  • polygon (Polygon2D) –

    surrounding search polygon (view coordinates)

  • viewProjection (ViewWorldProjection) –

    Identification of view projection (window)

  • selCond (eSelectCondition) –

    True when elements inside rectangle must be selected only

  • filter (SelectionQuery) –

    Selection filter

  • isWorldPolygon (bool, default: False ) –

    true=world polygon, false=view polygon

Returns:

SelectByRect staticmethod

SelectByRect(
    cursorLeftBottomPoint: Point2D,
    cursorRightTopPoint: Point2D,
    viewProjection: ViewWorldProjection,
    selCond: eSelectCondition,
    filter: SelectionQuery,
) -> BaseElementAdapterList

Select an element by a point

Parameters:

  • cursorLeftBottomPoint (Point2D) –

    Coordinate of left bottom point where elements will be searching

  • cursorRightTopPoint (Point2D) –

    Coordinate of right top point where elements will be searching

  • viewProjection (ViewWorldProjection) –

    Identification of view projection (window)

  • selCond (eSelectCondition) –

    True when elements inside rectangle must be selected only

  • filter (SelectionQuery) –

    Selection filter

Returns: