Skip to content

eSurfaceTrimParam

Canonical path: NemAll_Python_Geometry.eSurfaceTrimParam

Bases: Enum

Trimming curve surface param for naturally trimmed surfaces

eTrimUndefined : eTrimUMinValue : Edge is trimming the surface by its u-min value. eTrimUMinValueReverse: Edge is trimming the surface by its u-min value in reverse order. eTrimUMaxValue : Edge is trimming the surface by its u-max value. eTrimUMaxValueReverse: Edge is trimming the surface by its u-max value in reverse order. eTrimVMinValue : Edge is trimming the surface by its v-min value. eTrimVMinValueReverse: Edge is trimming the surface by its v-min value inreverse order. eTrimVMaxValue : Edge is trimming the surface by its v-max value. eTrimVMaxValueReverse: Edge is trimming the surface by its v-max value in reverse order.

Attributes:

eTrimUMaxValue class-attribute instance-attribute

eTrimUMaxValue = 3

eTrimUMaxValueReverse class-attribute instance-attribute

eTrimUMaxValueReverse = 4

eTrimUMinValue class-attribute instance-attribute

eTrimUMinValue = 1

eTrimUMinValueReverse class-attribute instance-attribute

eTrimUMinValueReverse = 2

eTrimUndefined class-attribute instance-attribute

eTrimUndefined = 0

eTrimVMaxValue class-attribute instance-attribute

eTrimVMaxValue = 7

eTrimVMaxValueReverse class-attribute instance-attribute

eTrimVMaxValueReverse = 8

eTrimVMinValue class-attribute instance-attribute

eTrimVMinValue = 5

eTrimVMinValueReverse class-attribute instance-attribute

eTrimVMinValueReverse = 6