Skip to content

LayoutMasterData

Canonical path: NemAll_Python_BaseElements.LayoutMasterData

Representation of a print layout

This class is a representation of a print layout and contains all the main settings specific for it, such as sheet size, margins or type of layout header.

Methods:

Attributes:

  • BackgroundType (None) –

    Set/get the background type (0-none, 1- color, 2-filling/gradient filling, 3 texture)

  • Border (None) –

    Set/get the border

  • Filling (None) –

    Set/get the filling

  • LayoutHeaderOffsetX (None) –

    Set/get the horizontal distance between legend frame and inner line of border

  • LayoutHeaderOffsetY (None) –

    Set/get the vertical distance between legend frame and inner line of border

  • LayoutHeaderType (None) –

    Set/get the header type (0-none, 1-stamp, 2-legend)

  • Legend (None) –

    Set/get the legend

  • Margin (None) –

    Set/get the margin

  • SheetSize (None) –

    Set/get the size of the sheet

  • Stamp (None) –

    Set/get the stamp

  • Texture (None) –

    Set/get the texture

  • UseBorder (None) –

    Set/get the use border state

  • UseMargins (None) –

    Set/get the use margins state

  • UseProperties (None) –

    Set/get the use properties state

BackgroundType property

BackgroundType: None

Set/get the background type (0-none, 1- color, 2-filling/gradient filling, 3 texture)

:type: None

Border property

Border: None

Set/get the border

:type: None

Filling property

Filling: None

Set/get the filling

:type: None

LayoutHeaderOffsetX property

LayoutHeaderOffsetX: None

Set/get the horizontal distance between legend frame and inner line of border

:type: None

LayoutHeaderOffsetY property

LayoutHeaderOffsetY: None

Set/get the vertical distance between legend frame and inner line of border

:type: None

LayoutHeaderType property

LayoutHeaderType: None

Set/get the header type (0-none, 1-stamp, 2-legend)

:type: None

Legend property

Legend: None

Set/get the legend

:type: None

Margin property

Margin: None

Set/get the margin

:type: None

SheetSize property

SheetSize: None

Set/get the size of the sheet

:type: None

Stamp property

Stamp: None

Set/get the stamp

:type: None

Texture property

Texture: None

Set/get the texture

:type: None

UseBorder property

UseBorder: None

Set/get the use border state

:type: None

UseMargins property

UseMargins: None

Set/get the use margins state

:type: None

UseProperties property

UseProperties: None

Set/get the use properties state

:type: None

__init__

__init__()

Initialize