Skip to content

Symbol3DProperties

Canonical path: NemAll_Python_BasisElements.Symbol3DProperties

Properties of the terrain point

Methods:

Attributes:

ControlPointOffset property

ControlPointOffset: None

Control point offset

DescriptionText property

DescriptionText: None

Description text (label)

Height property

Height: None

Symbol height

IsScaleDependent property

IsScaleDependent: None

Whether the point is to be scale dependent

IsStation property

IsStation: None

Whether the point is a station

PrimaryPointNumber property

PrimaryPointNumber: None

Primary point number

RotationAngle property

RotationAngle: None

Rotation angle

SecondaryPointNumber property

SecondaryPointNumber: None

Secondary point number

StationCode property

StationCode: None

Point code or station depending on the value of IsStation property.

SymbolID property

SymbolID: None

Symbol ID

Width property

Width: None

Symbol width

__eq__

__eq__(prop: Symbol3DProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string