Skip to content

BitmapAreaProperties

Canonical path: NemAll_Python_BasisElements.BitmapAreaProperties

Properties of the bitmap area.

Methods:

Attributes:

BitmapName property

BitmapName: None

Property for bitmap name of the bitmap area

:type: None

DirectionToReferenceLine property

DirectionToReferenceLine: None

Property for direction to reference line

:type: None

ReferencePoint property

ReferencePoint: None

Property for reference point

:type: None

RotationAngle property

RotationAngle: None

Property for rotation angle

:type: None

TransparentColor property

TransparentColor: None

Property for transparent color

:type: None

TransparentColorTolerance property

TransparentColorTolerance: None

Property for transparent color tolerance

:type: None

UseDirectionToReferenceLine property

UseDirectionToReferenceLine: None

Property for usage of direction to reference line

:type: None

UseMetricalValues property

UseMetricalValues: None

Property for metrical values

:type: None

UsePixelMask property

UsePixelMask: None

Property for usage of mask black pixels

:type: None

UseReferencePoint property

UseReferencePoint: None

Property for usage of reference point

:type: None

UseRepeatTile property

UseRepeatTile: None

Property for repeat tile

:type: None

XOffset property

XOffset: None

Property for X offset value

:type: None

XScalingFactor property

XScalingFactor: None

Property for X scaling factor

:type: None

YOffset property

YOffset: None

Property for Y offset value

:type: None

YScalingFactor property

YScalingFactor: None

Property for Y scaling factor

:type: None

__eq__

__eq__(prop: BitmapAreaProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert the list to a string

Returns:

  • str

    List values as string