Skip to content

Anchor

Canonical path: NemAll_Python_Precast.Anchor

Methods:

  • __init__

    Overloaded function. See individual overloads.

__init__ overloaded

__init__(
    id: int,
    fromId: int,
    fromPos: AnchorBorderPosition,
    toId: int,
    toPos: AnchorBorderPosition,
)

Constructor

Parameters:

  • Anchor

    ID

  • From

    cell ID

  • From

    cell pos

  • To

    cell ID

  • To

    cell pos

__init__(
    id: int,
    fromId: int,
    fromPos: AnchorBorderPosition,
    toId: int,
    toPos: AnchorBorderPosition,
    align: bool,
    offsetX: float,
    offsetY: float,
)

Constructor

Parameters:

  • Anchor

    ID

  • From

    cell ID

  • From

    cell pos

  • To

    cell ID

  • To

    cell pos

  • Offset

    x

  • Offset

    y

__init__(
    id: int,
    fromPos: AnchorBorderPosition,
    toId: int,
    toPos: AnchorBorderPosition,
)

Constructor

Parameters:

  • Anchor

    ID

  • From

    cell pos

  • To

    cell ID

  • To

    cell pos

__init__(
    id: int,
    fromPos: AnchorBorderPosition,
    toId: int,
    toPos: AnchorBorderPosition,
    offsetX: float,
    offsetY: float,
)

Constructor

Parameters:

  • Anchor

    ID

  • From

    cell pos

  • To

    cell ID

  • To

    cell pos

  • Offset

    x

  • Offset

    y

__init__(
    id: int,
    fromCell: Cell,
    fromPos: AnchorBorderPosition,
    toCell: Cell,
    toPos: AnchorBorderPosition,
)

Constructor

Parameters:

  • Anchor

    ID

  • From

    cell

  • From

    cell pos

  • To

    cell

  • To

    cell pos

__init__(
    id: int,
    fromCell: Cell,
    fromPos: AnchorBorderPosition,
    toCell: Cell,
    toPos: AnchorBorderPosition,
    align: bool,
    offsetX: float,
    offsetY: float,
)

Constructor

Parameters:

  • Anchor

    ID

  • From

    cell

  • From

    cell pos

  • To

    cell

  • To

    cell pos

  • Offset

    x

  • Offset

    y