Skip to content

LegendProperties

Canonical path: NemAll_Python_Precast.LegendProperties

Methods:

  • __init__

    Overloaded function. See individual overloads.

Attributes:

  • EntryNr (None) –

    Entry number of legend props

  • FileEntrPath (None) –

    File entry path of legend props

  • FileNr (None) –

    File number of legend props

  • MaxHeight (None) –

    Max height of legend props

  • MaxWidth (None) –

    Max width of legend props

EntryNr property

EntryNr: None

Entry number of legend props

Value type: int

:type: None

FileEntrPath property

FileEntrPath: None

File entry path of legend props

Value type: EFileEntryPath enum

:type: None

FileNr property

FileNr: None

File number of legend props

Value type: int

:type: None

MaxHeight property

MaxHeight: None

Max height of legend props

Value type: double

:type: None

MaxWidth property

MaxWidth: None

Max width of legend props

Value type: double

:type: None

__init__ overloaded

__init__()

Initialize

__init__(
    fileEntryPath: FileEntryPath,
    fileNr: int,
    entryNr: int,
    maxHeight: float,
    maxWidth: float,
)

Constructor