Skip to content

Page

Canonical path: NemAll_Python_Precast.Page

Methods:

  • __init__

    Overloaded function. See individual overloads.

  • add_anchor

    Adds an anchor to the page

  • add_anchors

    Adds anchors to the page

  • add_cell

    Adds a cell (labelStyle/legend/view) to the page

Attributes:

  • DrawingFile (None) –

    Sets the drawing file where the page should be placed

DrawingFile property

DrawingFile: None

Sets the drawing file where the page should be placed

Value type: int

:type: None

__init__ overloaded

__init__(doc: DocumentAdapter, pageNr: int, anchors: list)

Constructor

Parameters:

  • Anchors

    BaseReferenceModelElements

__init__(
    doc: DocumentAdapter, pageNr: int, anchors: list, conditionTemplate: str
)

Constructor

Parameters:

  • Anchors

    BaseReferenceModelElements

__init__(
    doc: DocumentAdapter,
    pageNr: int,
    anchors: list,
    size: MinMax2D,
    centeringCells: bool,
)

Constructor

Parameters:

  • Anchors

    BaseReferenceModelElements

__init__(
    doc: DocumentAdapter,
    pageNr: int,
    anchors: list,
    size: MinMax2D,
    centeringCells: bool,
    conditionTemplate: str,
)

Constructor

Parameters:

  • Anchors

    BaseReferenceModelElements

__init__(
    doc: DocumentAdapter,
    pageNr: int,
    scale: float,
    anchors: list,
    size: MinMax2D,
    centeringCells: bool,
)

Constructor

Parameters:

  • Anchors

    BaseReferenceModelElements

__init__(
    doc: DocumentAdapter,
    pageNr: int,
    scale: float,
    anchors: list,
    size: MinMax2D,
    centeringCells: bool,
    conditionTemplate: str,
)

Constructor

Parameters:

  • Anchors

    BaseReferenceModelElements

__init__(
    doc: DocumentAdapter,
    pageNr: int,
    scales: list,
    anchors: list,
    size: MinMax2D,
    centeringCells: bool,
)

Constructor

Parameters:

  • Anchors

    BaseReferenceModelElements

__init__(
    doc: DocumentAdapter,
    pageNr: int,
    scales: list,
    anchors: list,
    size: MinMax2D,
    centeringCells: bool,
    conditionTemplate: str,
)

Constructor

Parameters:

  • Anchors

    BaseReferenceModelElements

add_anchor

add_anchor(anchor: Anchor)

Adds an anchor to the page

Parameters:

  • Anchor

    to add

add_anchors

add_anchors(anchors: list)

Adds anchors to the page

Parameters:

  • Anchors

    to add

add_cell

add_cell(cell: Cell)

Adds a cell (labelStyle/legend/view) to the page

Parameters:

  • Cell

    to add