Skip to content

title: Page Properties description: @brief Wrapper for page properties of elementplan


PageProperties

Canonical path: NemAll_Python_Precast.PageProperties

@brief Wrapper for page properties of elementplan

Methods:

  • __init__

    Overloaded function. See individual overloads.

Attributes:

  • FixedScale (float) –

    Get the Fixed scaleof the page

  • Label (str) –

    Get the Label of the page

  • ScaleType (int) –

    Get the Scale type of the page

  • SizeType (int) –

    Get the Size type of the page

FixedScale property writable

FixedScale: float

Get the Fixed scaleof the page

Label property writable

Label: str

Get the Label of the page

ScaleType property writable

ScaleType: int

Get the Scale type of the page

SizeType property writable

SizeType: int

Get the Size type of the page

__init__ overloaded

__init__(label: str, sizeType: int, scaleType: int, fixedScale: float)

@brief Creates a helper to fill python palette for UVS Elementplan @param label Label of the page @param sizeType Size type of the page (Fixed | AutomaticSelection) @param scaleType Scale type of the page (ScaleAutomaticSelection | ScaleFixed | MaximumSize) @param fixedScale Fixed scale

__init__(element: PageProperties)

Copy constructor

Parameters:

Placeholder