PagePropertiesList
Canonical path: NemAll_Python_Precast.PagePropertiesList
List for PageProperties objects
__contains__
__contains__(value: PageProperties) -> bool
Check for a value in the list
Parameters:
-
value
(PageProperties
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: PageProperties)
__eq__
__eq__(compare_list: PagePropertiesList) -> bool
Compare two lists
Parameters:
-
compare_list
(PagePropertiesList
) –List to compare
Returns:
-
bool
–Lists are equal state
__getitem__
__getitem__(index: int) -> PageProperties
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
PageProperties
–Value for the index
__iadd__
__iadd__(eleList: list) -> PagePropertiesList
Add a list
Parameters:
-
eleList
(list
) –PageProperties list
Returns:
-
PagePropertiesList
–Lists with the added elements
__init__
overloaded
Initialize
__init__(ele: PageProperties)
Constructor with a list of PageProperties
Parameters:
-
eleList
(list
) –PageProperties list
__setitem__
__setitem__(index: int | slice, value: PageProperties)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(PageProperties
) –Value to item
append
append(value: PageProperties)
extend
overloaded
extend(iterable: PagePropertiesList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(PagePropertiesList
) –Iterable to add
Extend the list
Parameters:
-
eleList
(list
) –PageProperties list
Placeholder