Plan
Canonical path: NemAll_Python_Precast.Plan
Methods:
-
__init__
–Overloaded function. See individual overloads.
-
add_page
–Adds a page to the plan
-
create
–Overloaded function. See individual overloads.
Attributes:
-
DrawingFile
(None
) –Sets the drawing file where the elementplan should be placed
-
Offset
(None
) –Sets the offset of the plan
DrawingFile
property
Sets the drawing file where the elementplan should be placed
Value type: int
:type: None
Offset
property
Sets the offset of the plan
Value type: Allplan::Geometry::Point2D
:type: None
__init__
overloaded
__init__(doc: DocumentAdapter)
Constructor
__init__(arg2: DocumentAdapter, doc: BaseElementAdapterList)
Constructor
create
overloaded
create(elemPlan: BaseElementAdapter) -> bool
Creates the elementplan
Parameters:
-
Allplan
–:IFW::ElementAdapter::BaseElementAdapter:-> created elementplan
create(
elemPlan: BaseElementAdapter, baseElements: BaseElementAdapterList
) -> bool
Creates the elementplan
Parameters:
-
Allplan
–:IFW::ElementAdapter::BaseElementAdapter:-> created elementplan
-
Allplan
–:IFW::ElementAdapter::BaseElementAdapterList:-> elements to create
Placeholder