Skip to content

View

Canonical path: NemAll_Python_Precast.View

Bases: Cell

__init__ overloaded

__init__(
    doc: DocumentAdapter, cellId: int, direction: Direction, rotation: Rotation
)

Constructor

__init__(
    doc: DocumentAdapter,
    cellId: int,
    direction: Direction,
    rotation: Rotation,
    viewProps: ViewProperties,
)

Constructor

Parameters:

  • View

    properties

__init__(
    doc: DocumentAdapter,
    cellId: int,
    direction: Direction,
    rotation: Rotation,
    viewProps: ViewProperties,
    conditionTemplate: str,
)

Constructor

Parameters:

  • View

    properties

  • Condition

    template

create

create(
    elements: BaseElementAdapterList,
    position: Point2D,
    view: BaseElementAdapter,
) -> bool

Creates a standalon local uvs view without plan

Parameters:

  • Allplan

    :IFW::ElementAdapter::BaseElementAdapterList:-> elements of the view

  • Allplan

    :Geometry::Point2D:-> position of the view

  • Allplan

    :IFW::ElementAdapter::BaseElementAdapter:-> created view

Placeholder