Plane connection

The elements of a PythonPart can have a plane connection. The creation of the plane connection can be done by adding a Plane references dialog in the pyp-file. This entry creates a PlaneReferences object, that can be used to get the plane heights as follows:

plane_ref: AllplanArchElements.PlaneReferences = build_ele.PlaneReferences.value

abs_bottom_elevation = plane_ref.GetAbsBottomElevation()
abs_top_elevation    = plane_ref.GetAbsTopElevation()

height = abs_top_elevation - abs_bottom_elevation

cuboid_geo = AllplanGeo.Polyhedron3D.CreateCuboid(build_ele.Width.value, build_ele.Depth.value, height)
../../_images/PlaneConnection.png

When the plane heights are changed in the Allplan project, the PythonParts with a plane connection are checked for a height change and, if necessary, a new calculation of the PythonPart is executed.

An example of a plane connection is given in the files

…\etc\Examples\PythonParts\BasisExamples\PlaneConnection.pyp
…\etc\PythonPartsExampleScripts\BasisExamples\PlaneConnection.py

The complete documentation of the members from the PlaneReferences and ReferencePlaneID class can be found here: