class PlaneReferences

class NemAll_Python_ArchElements.PlaneReferences

Bases: BasePlaneReferences

Implementation of the plane references

class PlaneReferenceDependency

Bases: enum

Plane reference Dependency

__module__ = 'NemAll_Python_ArchElements'
eAbsElevation = NemAll_Python_ArchElements.PlaneReferenceDependency.eAbsElevation
eBottomPlane = NemAll_Python_ArchElements.PlaneReferenceDependency.eBottomPlane
eTopPlane = NemAll_Python_ArchElements.PlaneReferenceDependency.eTopPlane
names = {'eAbsElevation': NemAll_Python_ArchElements.PlaneReferenceDependency.eAbsElevation, 'eBottomPlane': NemAll_Python_ArchElements.PlaneReferenceDependency.eBottomPlane, 'eTopPlane': NemAll_Python_ArchElements.PlaneReferenceDependency.eTopPlane}
values = {0: NemAll_Python_ArchElements.PlaneReferenceDependency.eAbsElevation, 1: NemAll_Python_ArchElements.PlaneReferenceDependency.eBottomPlane, 2: NemAll_Python_ArchElements.PlaneReferenceDependency.eTopPlane}
GetAbsBottomElevation() float

Get the absolute bottom elevation

Returns:

Absolute bottom elevation

GetAbsTopElevation() float

Get the absolute top elevation

Returns:

Absolute top elevation

GetBottomElevation() float

Get the bottom plane elevation

Returns:

Bottom plane elevation

GetBottomPlaneDependency() PlaneReferenceDependency

Get the bottom plane dependency

Returns:

Bottom plane dependency

GetDocument() DocumentAdapter

Get the document

Returns:

Document

GetReferenceElement() BaseElementAdapter

Get the reference element for the plane

GetTopElevation() float

Get the top plane elevation

Returns:

Top plane elevation

GetTopPlaneDependency() PlaneReferenceDependency

Get the top plane dependency

Returns:

Top plane dependency

SetBottomElevation(elevation: float) None

Set the bottom plane elevation

Args:

elevation:  Elevation

SetBottomPlaneDependency(dependency: PlaneReferenceDependency) None

Set the bottom plane dependency

Args:

dependency:  Dependency

SetBottomToBottom(planeRef: PlaneReferences) None

Set the bottom level to the bottom level of the source plane reference

Args:

planeRef:  Source plane reference

SetBottomToTop(planeRef: PlaneReferences) None

Set the bottom level to the top level of the source plane reference

Args:

planeRef:  Source plane reference

SetDocument(doc: DocumentAdapter) None

Set the document

Args:

doc:  Document

SetReferenceElement(refElement: BaseElementAdapter) None

Set the reference element for the plane

Args:

refElement:  Reference element

SetTopElevation(elevation: float) None

Set the top plane elevation

Args:

elevation:  Elevation

SetTopPlaneDependency(dependency: PlaneReferenceDependency) None

Set the top plane dependency

Args:

dependency:  Dependency

SetTopToBottom(planeRef: PlaneReferences) None

Set the top level to the bottom level of the source plane reference

Args:

planeRef:  Source plane reference

SetTopToTop(planeRef: PlaneReferences) None

Set the top level to the top level of the source plane reference

Args:

planeRef:  Source plane reference

__init__(...)
__init__(doc: DocumentAdapter, refElement: BaseElementAdapter) None

Constructor

Args:

doc:         Document
refElement:  Reference element for the plane (if current exist)

__init__(element: PlaneReferences) None

Copy constructor

Args:

element:  Element to copy

__repr__() str

Convert to string

property AdaptTopLevelToPlane: int

Get the top level to plane adaption

Set the top level to plane adaption

property BottomElevation: double

Get the bottom plane elevation

Set the bottom plane elevation

property Direction: int

Get the direction

Set the direction

property Document: DocumentAdapter

Get the document

Set the document

property LowerPlane: ReferencePlaneID

Get the lower plane

Set the lower plane

property MaxHeight: float

Get the maximal height

Set the maximal height

property ReferenceElement: BaseElementAdapter

Get the reference element for the plane

Set the reference element for the plane

property TopElevation: double

Get the top plane elevation

Set the top plane elevation

property UpperPlane: ReferencePlaneID

Get the upper plane

Set the upper plane

__module__ = 'NemAll_Python_ArchElements'
eAbsElevation = NemAll_Python_ArchElements.PlaneReferenceDependency.eAbsElevation
eBottomPlane = NemAll_Python_ArchElements.PlaneReferenceDependency.eBottomPlane
eTopPlane = NemAll_Python_ArchElements.PlaneReferenceDependency.eTopPlane