class BaseElementAdapter¶
- class NemAll_Python_IFW_ElementAdapter.BaseElementAdapter¶
Implementation of the base element adapter
BaseElementAdapter is used inside the IFW as general element class, e.g. as result of an element selection. The class is created as adapter to avoid future IFW changes if the internal CAD data structure will be changed.
The class has some member functions to get the general element data like name, geometry, common properties, …
The adapter includes also the DocumentAdapter, which can be used to get the access to the internal CAD data structure.
- FromGUID(guid: GUID, doc: DocumentAdapter) BaseElementAdapter ¶
Get elements from GUID
- Args:
guid:  GUID of the element
doc:   Document- Returns:
Document
- FromNOIGUID(guidstr: str, doc: DocumentAdapter) BaseElementAdapter ¶
Get elements from NOI GUID
- Args:
guidStr:  NOI-GUID string of the element
doc:      Document- Returns:
Document
- GetArchElementType() ArchElementType ¶
Check the type of an architectural element (PRGBER_ELEM_ARCH)
- Returns:
Arch Element type
- GetAttributes(readState: eAttibuteReadState)¶
Get the attributes
- Args:
readState:  Attribute read state
- Returns:
Attributes
- GetCommonProperties() CommonProperties ¶
Get the common properties of the element
- Returns:
Common properties of the element
- GetDisplayName() str ¶
Get the displace name of the element
- Returns:
Display name of the element
- GetDocument() DocumentAdapter ¶
Get the document
- Returns:
Document
- GetDrawingfileNumber() int ¶
Get the drawing file number of the element
- Returns:
Drawing file number of the element / negative means drawing is in passive mode
- GetElementAdapterType() ElementAdapterType ¶
Get the type of the element
- Returns:
Type ID of the element
- GetElementUUID() GUID ¶
Get the UUID of the element
- Returns:
UUID of the element
- GetGeometry() Any ¶
Get elements geometry
- Returns:
Document
- GetGroundViewArchitectureElementGeometry() Any ¶
Get ground view geometry of an architecture element (if exist)
- Returns:
Geometry
- GetModelElementUUID() GUID ¶
Get the UUID of the model element
- Returns:
UUID of the element
- GetModelGeometry() Any ¶
Get element model geometry
- Returns:
Geometry
- GetParentElementAdapterType() ElementAdapterType ¶
Get the type of the parent element
- Returns:
Type ID of the parent element
- GetPureArchitectureElementGeometry() Any ¶
Get the pure geometry of an architecture element (if exist). The geometry is without openings, …
- Returns:
Geometry
- GetTimeStamp() int ¶
Get the time stamp of the element
- Returns:
Time stamp of the element creation
- Is3DElement() bool ¶
Get the 3D state of the element
- Returns:
Element is a 3D element: true/false
- IsActive() bool ¶
Get the activation state of the element
- Returns:
True, if the element is activated
- IsChildParentType(childType: GUID, parentType: GUID) bool ¶
Check for child (current element) and parent type connection
- Args:
childType:   Type of the element
parentType:  Type of the parent element- Returns:
Child and parent are connected by the define types
- IsDeleted() bool ¶
Get the deleted state of the element
- Returns:
True, if the element is deleted
- IsGeneralElement() bool ¶
Check if element is general (PRGBER_ELEM_ALLG)
- Returns:
Element is general (PRGBER_ELEM_ALLG)
- IsInActiveDocument() bool ¶
If element is in active document return true.
- Returns:
true if element is in active document
- IsInActiveLayer() bool ¶
If element is in active layer return true.
- Returns:
true if element is in active layer.
- IsInMacro() bool ¶
Check if element has parent object
- Returns:
Element has parent
- IsLabelElement() bool ¶
Check if element is a part of some label (Variables Textbild)
- Returns:
Element is a part of some label: true/false
- IsNull() bool ¶
Check for an empty element
- Returns:
Element is empty: true/false
- IsValidForSelectFace() bool ¶
Check if element is valid for face select
- Returns:
Element is valid for face select
- SetVisibilityState(visible: bool) None ¶
Set the visibility state of the element
- Args:
visible:  She visibility state to set
- __eq__(...)¶
- __eq__(element: BaseElementAdapter) bool ¶
Equal operator
- Args:
element:  Element to compare
- Returns:
Elements are equal: true/false
- __eq__(eleTypeUUID: GUID) bool ¶
Equal operator for checking the element adapter type UUID
- Args:
eleTypeUUID:  Element type UUID
- Returns:
Element has the type: true/false
- __init__(...)¶
- __init__() None ¶
- __init__(element: BaseElementAdapter) None ¶
Copy constructor
- Args:
element:  Element
- __ne__(...)¶
- __ne__(eleType: BaseElementAdapter) bool ¶
Not equal operator for checking the element type
- Args:
eleType:  Element type
- Returns:
Element has not the type: true/false
- __ne__(eleType: GUID) bool ¶
Not equal operator for checking the element type
- Args:
eleType:  Element type
- Returns:
Element has not the type: true/false
- __repr__() str ¶
Convert to string
- __module__ = 'NemAll_Python_IFW_ElementAdapter'¶
- class NemAll_Python_IFW_ElementAdapter.ArchElementType¶
- __module__ = 'NemAll_Python_IFW_ElementAdapter'¶
- __slots__ = ()¶
- tInvalid = NemAll_Python_IFW_ElementAdapter.ArchElementType.tInvalid¶
- tSheet = NemAll_Python_IFW_ElementAdapter.ArchElementType.tSheet¶
- tSolid = NemAll_Python_IFW_ElementAdapter.ArchElementType.tSolid¶
- tWire = NemAll_Python_IFW_ElementAdapter.ArchElementType.tWire¶
- values = {0: NemAll_Python_IFW_ElementAdapter.ArchElementType.tInvalid, 1: NemAll_Python_IFW_ElementAdapter.ArchElementType.tWire, 2: NemAll_Python_IFW_ElementAdapter.ArchElementType.tSheet, 3: NemAll_Python_IFW_ElementAdapter.ArchElementType.tSolid}¶