class BaseElementAdapterList¶
- class NemAll_Python_IFW_ElementAdapter.BaseElementAdapterList¶
Implementation of the base element adapter list
The BaseElementAdapterList is a general container for the BaseElementAdapter
- __getitem__(index: int) BaseElementAdapter ¶
Get the item for the index
- __iadd__(elements: BaseElementAdapterList) BaseElementAdapterList ¶
Add elements to the list
- Args:
elements:  Elements.
- __init__(...)¶
- __init__() None ¶
- __init__(elements: List[BaseElementAdapter]) None ¶
Constructor
- Args:
elements:  Initializer list with the elements
- __init__(eleList: BaseElementAdapterList) None ¶
Copy constructor
- Args:
eleList:  List to move
- __iter__() Iterator[BaseElementAdapter] ¶
Get the iterator
- __len__() int ¶
Get the length of the list
- Returns:
Length of the list
- __repr__() str ¶
Get a string from the list items
- append(element: BaseElementAdapter) None ¶
Append an element
- Args:
element:     Element to append
- clear() None ¶
Clear the list
- __module__ = 'NemAll_Python_IFW_ElementAdapter'¶