class ReferencePlaneID¶
- class NemAll_Python_ArchElements.ReferencePlaneID¶
Bases:
instance
struct for handling reference plane IDs
- ChangeModel(inputModelGuid: GUID) None ¶
change model id to another
- Args:
inputModelGuid:  
- Invalidate() None ¶
Set values to undefined state
- IsDefaultLowerPlane() bool ¶
Find out if reference plane is default lower reference plane
- Returns:
true if ref plane is default lower ref plane
- IsDefaultUpperPlane() bool ¶
Find out if reference plane is default upper reference plane
- Returns:
true if ref plane is default upper ref plane
- IsDocumentRefSurface() bool ¶
Find out if reference surface is from document
- Returns:
true is reference surface from document (not in model)
- IsInModel() bool ¶
Find out if refrence plane is in model
- Returns:
true if ref plane is in model
- IsValid() bool ¶
Get validity of ref plane
- Returns:
true if ref plane is valid
- SetCustomLowerPlane() None ¶
Set values to custom lower state
- SetCustomUpperPlane() None ¶
Set values to custom upper state
- __eq__(other: ReferencePlaneID) object ¶
- Args:
other:  
- __init__(...)¶
- __init__() None ¶
- __init__(modelGuid: GUID, planeId: int) None ¶
Constructor
- Args:
modelGuid:  
planeId:    
- __init__(element: ReferencePlaneID) None ¶
Copy constructor
- Args:
element:  Element to copy
- __lt__(other: ReferencePlaneID) object ¶
- Args:
other:  
- __ne__(other: ReferencePlaneID) object ¶
- Args:
other:  
- __reduce__()¶
- __repr__() str ¶
Convert to string
- property ModelGuid¶
- property PlaneId¶
- __module__ = 'NemAll_Python_ArchElements'¶