Handle types

The handle types are used in the HandleProperties class to set the layout of the handle. If no type is set, a filled circle is drawn.

class NemAll_Python_IFW_Input.ElementHandleType

Element handle type

__init__() None
__repr__() str
HANDLE_ARROW = ElementHandleType:    SymbolType = 35
HANDLE_CIRCLE = ElementHandleType:    SymbolType = 37
HANDLE_SQUARE_BLUE = ElementHandleType:    SymbolType = 30
HANDLE_SQUARE_EMPTY = ElementHandleType:    SymbolType = 42
HANDLE_SQUARE_RED = ElementHandleType:    SymbolType = 28
HANDLE_SQUARE_RIGHT = ElementHandleType:    SymbolType = 33
__module__ = 'NemAll_Python_IFW_Input'

The layout for the handle types is shown in the following table:

Layout

Type

../../_images/HandleArrow.png

HANDLE_ARROW

../../_images/HandleSquareBlue.png

HANDLE_SQUARE_BLUE

../../_images/HandleSquareEmpty.png

HANDLE_SQUARE_EMPTY

../../_images/HandleSquareRed.png

HANDLE_SQUARE_RED

../../_images/HandleSquareRight.png

HANDLE_SQUARE_RIGHT